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What readers are saying about Hello, Android

This is a most excellent book: very well written, easy to read, and fun.

In addition, any of Android’s quirks are explained along with just the

right amount of detail to ensure quality programming principles are

followed.

Anthony Stevens

Founder and CTO, PocketJourney and Top 20 Winner of

Google Android Competition

Ed Burnette covers an impressive amount of ground in a nicely com-

pact book while retaining the popular Pragmatic style. For the mate-

rial on 2D and 3D graphics alone, this is worthy of a spot in any

Android developer’s library.

Mark Murphy

Founder, CommonsWare

I remember when I �rst started to work with Android; it was like a

huge maze. With this book, the introduction would have been much

less painful. I am convinced that by reading this book new Android

programmers will have an easier start.

Gabor Paller

Senior Software Architect, OnRelay, Ltd.
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Changes (Cupcake Updates)
Android 1.5, also known as Cupcake, was released this spring. Cup-

cake contains a number of user- and programmer-facing changes that

broke examples in this book, and rendered some sections obsolete. This

series of updates will address these changes, and add new sections and

appendixes based on the Cupcake release.

All changes since the original printing will be �agged with an orange

color, like this text.

Please give us your feedback on the new and updated material by post-

ing in the forum1 or by submitting errata.

P1.5�July 21

This update contains the following changes:

� Chapter 7, The Connected World, on page 129: Added better sup-

port for the Android 1.5 soft keyboard.

� Chapter 8, Locating and Sensing, on page 158: Updated the Sen-

sorTest sample to use the new Sensors API, and the MyMap sample

to use the new setBuiltInZoomControls( ) method.

� Chapter 9, Putting SQL to Work, on page 175: Added missing imports

and string resources to the Events example.

P1.4�July 6

This update contains the following changes:

1. http://forums.pragprog.com/forums/67
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P1.3�JUNE 22 12

� Appendix B, on page 223: New appendix on how to create simple

Home screen app widgets. Readers: please look over this carefully

because it is all new material.

� Appendix A, on page 219: Updated for Cupcake. Moved java.beans

from the unsupported to the supported list.

P1.3�June 22

This update contains the following changes:

� Chapter 4, Exploring 2D Graphics, on page 73: Tried to clarify a

few parts that were confusing people.

� Chapter 5, Multimedia, on page 104: Updated for Cupcake. Changed

the recommended video format from MPEG-4 to H.263.

� Chapter 6, Storing Local Data, on page 119: Updated for Cupcake.

It is no longer necessary to use the mksdcard command.

P1.2�June 9

This update contains the following changes:

� Chapter 2, Key Concepts, on page 30: Updated for Cupcake. Added

a short explanation of widgets and a mention of upcoming native

development support. Took new screenshots with 1.5_r2 and ADT

0.9.1v200905011822-1621. Redid the architecture diagram to include

widgets.

� Chapter 3, Designing the User Interface, on page 44: Updated for

Cupcake. Took lots of new screenshots.

P1.1�May 26

This update contains the following changes:

� Chapter , Changes (Cupcake Updates), on the preceding page: New

section (you’re reading it now) that will detail the changes made in

each release.

� Chapter , Preface, on page 14: Updated for Cupcake.
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TODO IN FUTURE RELEASES 13

� Chapter 1, Quick Start, on page 20: Updated for Cupcake. Added

new material on Android Virtual Devices (AVDs). Took new screen-

shots with 1.5_r1 and ADT 0.9.1v200905011822-1621.

� Appendix B, on page 223: New appendix on writing widgets (just

a placeholder for now).

� Appendix C, on page 233: New appendix on signing and publishing

(just a placeholder for now).

� Updated all sample source code �les2 so they build and run with

1.5. I haven’t updated the text that describes the samples.

� Tested all samples on 1.5 �rmware on a real phone except for

MyMap.

� Various: Cleared up all outstanding errata.3

� Various: Fixed URLs that Google broke since the �rst printing.

TODO in future releases

Here are the items I’m working on next.

� Update Chapter 10, 3D Graphics in OpenGL, on page 195. Update

the OpenGL sample to use new API.

� Create Appendix C, on page 233.

2. http://www.pragprog.com/titles/eband/source_code

3. http://www.pragprog.com/titles/eband/errata
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Preface
Android is a new open source software toolkit for mobile phones that

was created by Google and the Open Handset Alliance. In a few years,

it’s expected to be found in millions of cell phones and other mobile

devices, making Android a major platform for application developers.

Whether you’re a hobbyist or a professional programmer, whether you

are doing it for fun or for pro�t, it’s time to learn more about developing

for Android. This book will help you get started.

What Makes Android Special?

There are already many mobile platforms on the market today, includ-

ing Symbian, iPhone, Windows Mobile, BlackBerry, Java Mobile Edi-

tion, Linux Mobile (LiMo), and more. When I tell people about Android,

their �rst question is often, Why do we need another mobile standard?

Where’s the �wow�?

Although some of its features have appeared before, Android is the �rst

environment that combines the following:

� A truly open, free development platform based on Linux and open

source: Handset makers like it because they can use and cus-

tomize the platform without paying a royalty. Developers like it

because they know that the platform �has legs� and is not locked

into any one vendor that may go under or be acquired.

� A component-based architecture inspired by Internet mashups:

Parts of one application can be used in another in ways not orig-

inally envisioned by the developer. You can even replace built-in

components with your own improved versions. This will unleash a

new round of creativity in the mobile space.

� Tons of built-in services out of the box: Location-based services use

GPS or cell tower triangulation to let you customize the user expe-

rience depending on where you are. A full-powered SQL database
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WHO SHOULD READ THIS BOOK? 15

lets you harness the power of local storage for occasionally con-

nected computing and synchronization. Browser and map views

can be embedded directly in your applications. All these built-in

capabilities help raise the bar on functionality while lowering your

development costs.

� Automatic management of the application life cycle: Programs are

isolated from each other by multiple layers of security, which will

provide a level of system stability not seen before in smart phones.

The end user will no longer have to worry about what applications

are active or close some programs so that others can run. Android

is optimized for low-power, low-memory devices in a fundamental

way that no previous platform has attempted.

� High-quality graphics and sound: Smooth, antialiased 2D vector

graphics and animation inspired by Flash are melded with 3D

accelerated OpenGL graphics to enable new kinds of games and

business applications. Codecs for the most common industry-

standard audio and video formats are built right in, including

H.264 (AVC), MP3, and AAC.

� Portability across a wide range of current and future hardware:

All your programs are written in Java and executed by Android’s

Dalvik virtual machine, so your code will be portable across

ARM, x86, and other architectures. Support for a variety of input

methods is included such as keyboard, touch, and trackball.

User interfaces can be customized for any screen resolution and

orientation.

Android offers a fresh take on the way mobile applications interact with

users, along with the technical underpinnings to make it possible. But

the best part of Android is the software that you are going to write for

it. This book will help you get off to a great start.

Who Should Read This Book?

The only requirement is a basic understanding of programming in Java

or a similar object-oriented language (C# will do in a pinch). You don’t

need any prior experience developing software for mobile devices. In

fact, if you do, it’s probably best if you try to forget that experience.

Android is so different that it’s good to start with an open mind.
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WHAT’S IN THIS BOOK? 16

What’s in This Book?

Hello, Android is divided into three parts. Roughly speaking, the book

progresses from less advanced to more advanced topics, or from more

common to less common aspects of Android.

Several chapters share a common example: an Android Sudoku game.

By gradually adding features to the game, you’ll learn about many

aspects of Android programming including user interfaces, multime-

dia, and the Android life cycle.

In Part I, we’ll start with an introduction to Android. This is where you’ll

learn how to install the Android emulator and how to use an integrated

development environment (IDE) to write your �rst program. Then we’ll

introduce a few key concepts like the Android life cycle. Programming

in Android is a little different from what you’re probably used to, so

make sure you get these concepts before moving on.

Part II talks about Android’s user interface, two-dimensional graphics,

multimedia components, and simple data access. These features will be

used in most programs you write.

Part III digs deeper into the Android platform. Here you’ll learn about

connecting to the outside world, location-based services, the built-in

SQLite database, and three-dimensional graphics.

At the end of the book, you’ll �nd appendices that cover the differences

between Android and Java Standard Edition (SE), how to create a wid-

get, and publishing your application.

What’s New for Cupcake?

Android 1.5 (Cupcake) introduced a number of enhancements to the

Android platform including support for soft (on-screen) keyboards, video

recording, and application widgets. Under the covers, there were over

1,000 changes to the Android API between 1.1 and 1.5.4

To accommodate the new version, every page and example in this book

has been reviewed and updated so it will work with 1.5. Most of the

changes were small but a few sections needed major revisions. If you’ve

read this book before then be sure to check out these updated chapters:

4. http://developer.android.com/sdk/1.5_r2/upgrading.html
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ONLINE RESOURCES 17

� Chapter 1, Quick Start, on page 20 includes instructions on using

target SDKs and Android Virtual Devices (AVDs).

� Chapter 8, Locating and Sensing, on page 158 now uses the new

SensorManager APIs.

� Chapter 10, 3D Graphics in OpenGL, on page 195 has been greatly

simpli�ed thanks to the new GLSurfaceView class.

In addition, by popular demand we’ve added two new appendices:

� Appendix B, on page 223 shows you how to create a Widget for the

Home screen. This is a new feature of Cupcake.

� Appendix C, on page 233 guides you through the steps of mak-

ing your application available for sale or for free on the Android

Market.

By the time you read this, Android 1.5 (or later) will be available for

all shipping Android devices. All new devices will have it installed, and

Google expects existing Android users to quickly upgrade. Therefore

this printing of the book will not cover version 1.1 or earlier.

Online Resources

At the website for this book, http://pragprog.com/titles/eband, you’ll �nd

the following:

� The full source code for all the sample programs used in this book

� An errata page, listing any mistakes in the current edition (let’s

hope that will be empty!)

� A discussion forum where you can communicate directly with the

author and other Android developers (let’s hope that will be full!)

You are free to use the source code in your own applications as you see

�t. Note: If you’re reading the PDF version of this book, you can also

click the little gray rectangle before the code listings to download that

source �le directly.

Fast-Forward >>

Although most authors expect you to read every word in their books, I

know you’re not going to do that. You want to read just enough to let

you get something done, and then maybe you’ll come back later and
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FAST -FORWARD >> 18

read something else to let you get another piece done. So, I’ve tried to

provide you with a little help so you won’t get lost.

Each chapter in this book ends with a �Fast-Forward >> section.� These

sections will provide some guidance for where you should go next when

you need to read the book out of order. You’ll also �nd pointers to other

resources such as books and online documentation here in case you

want to learn more about the subject.

So, what are you waiting for? The next chapter�Chapter 1, Quick Start,

on page 20�drops you right into the deep end with your �rst Android

program. Chapter 2, Key Concepts, on page 30 takes a step back and

introduces you to the basic concepts and philosophy of Android, and

Chapter 3, Designing the User Interface, on page 44 digs into the user

interface, which will be the most important part of most Android

programs.
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Part I

Introducing Android
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Chapter 1

Quick Start
Android combines the ubiquity of cell phones, the excitement of open

source software, and the corporate backing of Google and other Open

Handset Alliance members like Intel, TI, T-Mobile, and NTT DoCoMo.

The result is a mobile platform you can’t afford not to learn.

Luckily, getting started developing with Android is easy. You don’t even

need access to an Android phone�just a computer where you can

install the Android SDK and phone emulator.

In this chapter, I’ll show you how to get all the development tools

installed, and then we’ll jump right in and create a working applica-

tion: Android’s version of �Hello, World.�

1.1 Installing the Tools

The Android software development kit (SDK) works on Windows, Linux,

and Mac OS X. The applications you create, of course, can be deployed

on any Android devices.

Before you start coding, you need to install Java, an IDE, and the

Android SDK.

Java 5.0+

First you need a copy of Java. All the Android development tools require

it, and programs you write will be using the Java language. JDK 5 or 6

is required.

It’s not enough to just have a runtime environment (JRE); you need

the full development kit. I recommend getting the latest Sun JDK 6.0
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update from the Sun download site.1 Mac OS X users should get the

latest version of Mac OS X and the JDK from the Apple website.

To verify you have the right version, run this command from your shell

window. Here’s what I get when I run it:

C:\> java -version

java version "1.6.0_13"

Java(TM) SE Runtime Environment (build 1.6.0_13-b03)

Java HotSpot(TM) Client VM (build 11.3-b02, mixed mode, sharing)

You should see something similar, with version �1.6.something� or later.

Eclipse

Next, you should install a Java development environment if you don’t

have one already. I recommend Eclipse, because it’s free and because

it’s used and supported by the Google developers who created Android.

If you don’t want to use Eclipse (there’s always one in every crowd),

support for other IDEs such as NetBeans and JetBrains IDEA is avail-

able from their respective communities. Or if you’re really old-school,

you can forgo an IDE entirely and just use the command-line tools.2

The minimum version of Eclipse is 3.3.1, but you should always use

whatever is the most up-to-date production version. Note that you need

more than just the standard Eclipse SDK �classic� platform. Go to the

Eclipse downloads page,3 and pick �Eclipse IDE for Java Developers.�

Follow the directions there for downloading, unpacking, and installing

Eclipse into a suitable location (like C:\Eclipse on Windows).

Android

Next, download the latest Android SDK from Google. The Android down-

load page4 has packages for Windows, Mac OS X, and Linux. After

downloading the package that’s right for you, unpack the .zip �le to

a convenient directory (for example, C:\Google).

By default, the SDK will be expanded into a subdirectory like android-

sdk-windows-1.5_r2. This is your SDK install directory; make a note of the

full path so you can refer to it later.

1. http://java.sun.com/javase/downloads

2. See http://d.android.com/guide/developing/tools/index.html for documentation on the

command-line tools.
3. http://www.eclipse.org/downloads

4. http://d.android.com/sdk
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Figure 1.1: Installing the Android Development Toolkit

No special install program is needed but I do recommend you add the

SDK’s bin directory to your PATH. The next step is to start Eclipse and

con�gure it.

Eclipse Plug-In

To make development easier, Google has written a plug-in for Eclipse

called the Android Development Toolkit (ADT). To install the plug-in,

follow these steps (note these directions are for Eclipse 3.4�different

versions may have slightly different menus and options):

1. Start Eclipse, and select Help > Software Updates....

2. Click the Available Software tab if it’s not already selected.

3. Click the Add Site... button.

4. Enter the location of the Android update site: https://dl-ssl.google.

com/android/eclipse/. If you have trouble with this address, try

using http in the location instead of https.

Once you’ve �lled it out, the dialog box should look like Figure 1.1.

Click OK.

5. The Android site should now appear in the Available Software

view. Select the checkbox next to it, and then click Install.... If

you get an error message, then you may not have the right version

of Eclipse. I strongly recommend using either the prebuilt Eclipse

IDE for Java or the Eclipse IDE for Java EE Development pack-

ages, version 3.4 or newer.
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Joe Asks. . .

It Says �Connection Error,� So Now What?

If you get a connection error, the most likely cause is some kind
of �rewall erected by your system administrators. To get outside
the �rewall, you’ll need to con�gure Eclipse with the address
of your proxy server. This is the same proxy server you use for
your web browser, but unfortunately Eclipse isn’t smart enough
to pick up the setting from there.

To tell Eclipse about the proxy, select Preferences > Network
Connections, turn on the option for Manual proxy con�gura-
tion, enter the server name and port number, and click OK. If
you don’t see the option, you may be running an older ver-
sion of Eclipse. Try looking under Preferences > Install/Update,
or search the preferences for the word proxy.

If you have a custom install of Eclipse, then to use the Android

editors you will also need to install the Web Standard Tools (WST)

plug-in and all its prerequisites.

See the Web Tools platform home page5 for more details and down-

load links. These are already built into the recommended packages

mentioned earlier.

6. Click Next, accept the license agreements, and then click Finish

to start the download and install process.

7. Once the install is done, restart Eclipse.

8. When Eclipse comes back up, you may see a few error messages

because you need to tell it where the Android SDK is located.

Select Window > Preferences > Android (Eclipse > Preferences on

Mac OS X), and enter the SDK install directory you noted earlier.

Click OK.

Whew! Luckily, you have to do that only once (or at least once every

time a new version of ADT or Eclipse comes out). Now that everything

is installed, it’s time to write your �rst program.

5. http://www.eclipse.org/webtools
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1.2 Creating Your First Program

ADT comes with a built-in example program, or template, that we’re

going to use to create a simple �Hello, Android� program in just a few

seconds. Get your stopwatch ready. Ready? Set? Go!

Select File > New > Project... to open the New Project dialog box. Then

select Android > Android Project, and click Next.

Enter the following information:

Project name: HelloAndroid

Build Target: Android 1.5

Application name: Hello, Android

Package name: org.example.hello

Create Activity: Hello

When you’re done, it should look something like Figure 1.2, on the

following page.

Click Finish. The Android plug-in will create the project and �ll it in

with some default �les. Eclipse will build it and package it up so it will

be ready to execute. If you get an error about missing source folders,

select Project > Clean to �x it.

OK, that takes care of writing the program; now all that’s left is to try

running it. First we’ll run it under the Android Emulator.

1.3 Running on the Emulator

To run your Android program, go to the Package Explorer window,

right-click the HelloAndroid project, and select Run As > Android Appli-

cation. If you’re following along in Eclipse you may see an error dialog

like the one in Figure 1.3, on page 26. This indicates we haven’t told

the Emulator what kind of phone to emulate.

Creating an AVD

To do this, you need to create an Android Virtual Device (AVD), using

either Eclipse or the android avd command.6 It’s easier to use Eclipse,

so select Yes in the AVD Error dialog to open the AVD Manager. You

can open the manager again later by selecting Window > Android AVD

Manager.

In the AVD Manager dialog, �ll out the �elds for the new AVD as follows:

6. http://d.android.com/guide/developing/tools/avd.html
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Figure 1.2: New Android project
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Keeping Up with the Plug-In

The Android Eclipse plug-in is a work in progress that changes
much more often than the Android SDK. The version you down-
load may be different than the one I used when writing this
book, and it may contain a few, shall we say, idiosyncrasies. I
recommend you check the plug-in site monthly to pick up any
new features and �xes.

Figure 1.3: Missing Android Virtual Device (AVD)

Name: em15

Target: Android 1.5 - 1.5

SDCard: 128M

Skin: Default (HVGA)

This tells Eclipse to set up a generic device called �em15� which has

the Android 1.5 (Cupcake) �rmware installed. A 128MB virtual Secure

Digital (SD) Card will be allocated, along with a half-VGA (320x480)

display.

When you’re done you should see something like Figure 1.4, on the

following page. Due to updates in the plug-in since this was written

your screen may look slightly different.

Click on Create AVD (not Finish) to create the virtual device. A few sec-

onds later you should see a message that the device has been created.

Click OK, and then you can click Finish.

Let’s Try That Again
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Figure 1.4: Creating an AVD in Eclipse

Once you have a valid AVD, the Android emulator window will start

up and boot the Android operating system. The �rst time you do this,

it may take a minute or two, so be patient. If you see an error mes-

sage saying that the application is not responding, select the option to

continue waiting.

After the emulator window starts, Eclipse will send it a copy of your

program to execute. The application screen comes up, and your �Hello,

Android� program is now running (see Figure 1.5, on the next page).

That’s it! Congratulations on your �rst Android program.

Report erratum

this copy is (P1.5 printing, July 21, 2009)
Prepared exclusively for Trieu Nguyen

http://books.pragprog.com/titles/eband/errata/add?pdf_page=27


RUNNING ON THE EMULATOR 28

Figure 1.5: Running the �Hello, Android� program

Shortening the Turnaround

Starting the emulator is expensive. Think about it this way�
when you �rst turn on your phone, it needs to boot up just like
any computer system. Closing the emulator is just like turning off
the phone or pulling the batteries out. So, don’t turn it off!

Leave the emulator window running as long as Eclipse is run-
ning. The next time you start an Android program, Eclipse will
notice the emulator is already there and will just send it the new
program to run.

Report erratum

this copy is (P1.5 printing, July 21, 2009)
Prepared exclusively for Trieu Nguyen

http://books.pragprog.com/titles/eband/errata/add?pdf_page=28


RUNNING ON A REAL PHONE 29

1.4 Running on a Real Phone

Running an Android program on a physical device such as the T-Mobile

G1 during development is almost identical to running it on the emula-

tor. All you need to do is connect your phone to the computer with a

USB cable and install a special device driver.7 Close the emulator win-

dow if it’s already open. As long as the phone is plugged in, applications

will be loaded and run there instead.

When you’re ready to publish your application for others to use, there

are a few more steps you’ll need to take. Appendix C, on page 233 will

cover that in more detail.

1.5 Fast-Forward >>

Thanks to the Eclipse plug-in, creating a skeletal Android program

takes only a few seconds. In Chapter 3, Designing the User Interface, on

page 44, we’ll begin to �esh out that skeleton with a real application�a

Sudoku game. This sample will be used in several chapters to demon-

strate Android’s API.

But before delving into that, you should take a few minutes to read

Chapter 2, Key Concepts, on the following page. Once you grasp the

basic concepts such as activities and life cycles, the rest will be much

easier to understand.

Although the use of Eclipse to develop Android programs is optional,

I highly recommend it. If you’ve never used Eclipse before, you may

want to invest in a quick reference such as the Eclipse IDE Pocket

Guide [Bur05].

7. You can �nd the device driver and installation instructions at

http://d.android.com/guide/developing/device.html.
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Chapter 2

Key Concepts
Now that you have an idea of what Android is, let’s take a look at how it

works. Some parts of Android may be familiar, such as the Linux ker-

nel, OpenGL, and the SQL database. Others will be completely foreign,

such as Android’s idea of the application life cycle.

You’ll need a good understanding of these key concepts in order to write

well-behaved Android applications, so if you read only one chapter in

this book, read this one.

2.1 The Big Picture

Let’s start by taking a look at the overall system architecture�the key

layers and components that make up the Android open source software

stack. In Figure 2.1, on the next page, you can see the �20,000-foot�

view of Android. Study it closely�there will be a test tomorrow.

Each layer uses the services provided by the layers below it. Starting

from the bottom, the following sections highlight the layers provided by

Android.

Linux Kernel

Android is built on top of a solid and proven foundation: the Linux

kernel. Created by Linus Torvalds in 1991 while he was a student at

the University of Helsinki, Linux can be found today in everything from

wristwatches to supercomputers. Linux provides the hardware abstrac-

tion layer for Android, allowing Android to be ported to a wide variety

of platforms in the future.
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